Page 32 sur 207 PremièrePremière ... 222526272829303132333435363738394282132 ... DernièreDernière
Résultats de 311 à 320 sur 2063
  1. #311
    Cz&Co Avatar de Franck.A
    Inscrit
    juin 2005
    Messages
    7 638
    Merci / J'aime
    Cité(e)
    3 Post(s)
    Badgé(e)
    0 Sujet(s)
    Bonjour,

    Citation Envoyé par F1FNW Voir le message
    Hélas, j'ai bien aussi essayé cette façon de procéder, j'obtient immuablement la même barre de chargement qui reste à 0%.
    Deux questions pour essyer d'avancer :
    - Peux-tu STP (comme ici : NextStepRC : radio OpenTX DIY (MMag juin 2015)) poster ici le texte affiché par OpenTX dans la fenêtre de flashage ?
    - As-tu vérifié dans le gestionnaire de périphérique le n° de port com de ta radio quand elle est connectée au port USB ?

    Franck
    RC Aero Lab : PredimRC, radio DIY OpenTX NextStepRC, conception et optimisation d'aéromodèles.

  2. # ADS
    Circuit advertisement NextStepRC : radio OpenTX DIY (MMag juin 2015)
    Inscrit
    Always
    Messages
    Many
     

  3. #312
    Membre actif Avatar de xavtronic
    Inscrit
    septembre 2004
    Localisation
    Suisse
    Messages
    708
    Merci / J'aime
    Cité(e)
    0 Post(s)
    Badgé(e)
    0 Sujet(s)
    Bonjour,

    Je reviens sur le sujet car je n'ai pas pu beaucoup avancer ces derniers temps et je n'ai pas encore effectué toutes les commande nécessaire!

    Je me pose la question sur ces switch de navigation peuvent avantageusement remplacer ceux préconiser dans l'article?
    http://www.aliexpress.com/item/Size-...2_73_74_75,0_0



    L'écran LCD vous confirmer que le meilleure prix est celui-ci (environ 6$ par pièce)?
    http://www.aliexpress.com/item/4pcs-...2_73_74_75,0_0


    Une question plus technique pour Franck qui me trotte dans la tête depuis la parution de l'article et concernant le choix de l'arduino Mega, pourquoi ne pas avoir utiliser la DUE?
    Elle souffre de quelques problème de conception niveau HW (surtout manque de périphériques), mais n'aurait-elle pas été une bonne candidate?

    Est-ce que quelqu'un c'est lancé dans la réalisation d'un circuit imprimé regroupant le tout et directement connectable sur la Mega?
    Je suis entrain de réfléchir à la faisabilité, surtout à l'implémentation et avantages / inconvénients, d'une tel carte plutôt que d'avoir du câblage volant.

    A+
    Xavier

  4. #313
    Membre Sénior Avatar de F1FNW
    Inscrit
    juin 2008
    Localisation
    Corsica.
    Messages
    1 910
    Merci / J'aime
    Cité(e)
    8 Post(s)
    Badgé(e)
    0 Sujet(s)
    Citation Envoyé par Eleyone Voir le message
    Bonjour,

    Je suis nouveau ici bas, mais cela fais un bon moment que je suis ce thread.

    Je me suis lancé dans l'aventure de la radio custom à base de joystick (un saiteck cyborg 3D en port jeux) et d'arduino mega2560 sous OpenTX. J'ai, comme beaucoup ici, un écran en ST7920 avec lequell j'ai eu quelque mésaventure pour le faire fonctionner.

    Comme Wapata, j'ai galéré à le faire fonctionner, malgré avoir fais les câblages correcte (câblée/recâblé une bonne dizaine de fois). Il s'avéré que j'avais un jumper à souder sur la carte de l'écran pour que ce dernier fonctionne (sur la carte écran j'ai la référence 12864ZW, et le jumper est J1)
    Auparavant, j'avais acheté un écran de marque SainSmart qui possédé une platine pré-câblée avec des switchs pour le backlight, le contraste et sélectionner le mode de fonctionnement de l'écran (en parallèle comme dans notre montage, ou en série (3fils)), et il s’avérait qu'en mode parallèle, le constructeur avais mis une résistance de 0Ohm sur le circuit qui mettait automatiquement le circuit en cours-circuit. Du coup je ne peux que vous conseiller de regarder la référence de votre carte sur le net afin de voir comment l'activé pour un fonctionnement en parrallèle.
    Bonjour,

    Mon afficheur porte la ref: 12864B V2.0 il y a bien un marquage "J1" mais rien à souder là! Par contre, sur la droite, un marquage m'intrigue, "JP2 avec trois points et S d'un coté et P de l'autre"!

    J'ai aussi reçu une autre carte MEGA 2560 (identique à la première) et malgré un suivit de la procédure de flashage scrupuleuse, toujours rien... toujours bloqué après passage à l'USB. c'est pas mieux avec toute la procédure faite avec l'USBASP.
    là je craque et je vais laisser tomber...

    @rcch: je ne connais pas bien l'IDE d'arduino, mais regarde si tu peux t'en servir pour flasher le binaire compilé par compagnion9X...

    Avec ARDUINO, il prend pas les fichiers .bin ou .hex.

  5. #314
    Membre actif Avatar de xavtronic
    Inscrit
    septembre 2004
    Localisation
    Suisse
    Messages
    708
    Merci / J'aime
    Cité(e)
    0 Post(s)
    Badgé(e)
    0 Sujet(s)

    Post

    Hello,

    Citation Envoyé par F1FNW Voir le message
    Bonjour,
    J'ai aussi reçu une autre carte MEGA 2560 (identique à la première) et malgré un suivit de la procédure de flashage scrupuleuse, toujours rien... toujours bloqué après passage à l'USB. c'est pas mieux avec toute la procédure faite avec l'USBASP.
    là je craque et je vais laisser tomber...
    Ne jamais laisser tomber! C'est trop facile sinon

    1) Tu es sur des drivers pour l'USBASP?
    2) Drivers pour la MEGA?

    3) Sur quel port sont reconnu l'USBASP et la MEGA? (je travail sous Linux, mais je pense que c'est identique sous Windows)

    4) Il n'y aurait pas des droits ADMIN à activer pour accéder aux ports de sorties (USB dans notre cas ou émulation)

    5) Il y a quoi d'écrit lorsque tu exécutes les fichier *bat, etc.

    6) Une idée essaye de mettre le dossier avec les *.hex, *.bat, etc dans un nom court, sans espace et au plus près de la racine! (en théorie à l'heure actuelle ca ne devrait plus rien changer, mais ne sait-on jamais)

    7) @Franck : quel est la configuration des options minimum qui fonctionne? (pour le HEX de Open-tx)
    7') @F1FNW : Essaye de flasher que ce que Franck à donné pour la réponse si dessus!

    A+
    Xavier
    Dernière édition par xavtronic; 30/09/2015 à 13h57

  6. #315
    Nouveau membre
    Inscrit
    septembre 2015
    Messages
    2
    Merci / J'aime
    Cité(e)
    0 Post(s)
    Badgé(e)
    0 Sujet(s)
    Citation Envoyé par F1FNW Voir le message
    Mon afficheur porte la ref: 12864B V2.0 il y a bien un marquage "J1" mais rien à souder là! Par contre, sur la droite, un marquage m'intrigue, "JP2 avec trois points et S d'un coté et P de l'autre"!
    J'ai effectivement ce jumper, mais je ne l'ai pas utilisé.

    Ceci étant, j'ai trouvé ceci sur la toile concernant ta référence d'écran http://forum.hobbycomponents.com/vie...hp?f=39&t=1395 Si ça peux t'aider.

    Citation Envoyé par F1FNW Voir le message
    J'ai aussi reçu une autre carte MEGA 2560 (identique à la première) et malgré un suivit de la procédure de flashage scrupuleuse, toujours rien... toujours bloqué après passage à l'USB. c'est pas mieux avec toute la procédure faite avec l'USBASP.
    A tu vérifié le port de communication de la carte dans ton panneaux cofiguration (gestion des périphériques) ? A tu installer les pilotes arduino pour la carte ?

  7. #316
    Membre Sénior Avatar de F1FNW
    Inscrit
    juin 2008
    Localisation
    Corsica.
    Messages
    1 910
    Merci / J'aime
    Cité(e)
    8 Post(s)
    Badgé(e)
    0 Sujet(s)
    Citation Envoyé par Franck.A Voir le message
    Bonjour,


    Deux questions pour essyer d'avancer :
    - Peux-tu STP (comme ici : NextStepRC : radio OpenTX DIY (MMag juin 2015)) poster ici le texte affiché par OpenTX dans la fenêtre de flashage ?
    - As-tu vérifié dans le gestionnaire de périphérique le n° de port com de ta radio quand elle est connectée au port USB ?

    Franck
    Hello Franck,

    Je joint un fichier pour ce qui est des fusibles et du bootloader. ça a l'air bon...

    ensuite, je vais sous companion 2.1 et je règle la communication comme indiquée

    Programmateur STK500v2 et com8 (port indiqué pour CH340) et l'extention -D pour pas effacer l'eeprom.

    Ensuite dans préférence "heli, template, Frsky et ST7920.

    Je transfère le fichier dans "fichier, télécharger" et je demande le transfert dans la radio et là une barre apparaît et reste à 0%

    Je précise que je n'ai que la carte MEGA2560 reliée à l'USB et pas la radio complète!

    Je pense que tout est clair...

    Après flashage des fusibles et du bootloader, la LED "L" clignote.
    Fichiers joints Fichiers joints
    Dernière édition par F1FNW; 30/09/2015 à 14h16 Raison: Ajout fichier .PDF

  8. #317
    Membre Sénior Avatar de F1FNW
    Inscrit
    juin 2008
    Localisation
    Corsica.
    Messages
    1 910
    Merci / J'aime
    Cité(e)
    8 Post(s)
    Badgé(e)
    0 Sujet(s)
    Citation Envoyé par Eleyone Voir le message
    J'ai effectivement ce jumper, mais je ne l'ai pas utilisé.

    Ceci étant, j'ai trouvé ceci sur la toile concernant ta référence d'écran http://forum.hobbycomponents.com/vie...hp?f=39&t=1395 Si ça peux t'aider.



    A tu vérifié le port de communication de la carte dans ton panneaux cofiguration (gestion des périphériques) ? A tu installer les pilotes arduino pour la carte ?
    Ok, merci pour ces détails, mais dans l'absolu, l'afficheur n'est pas trop mon problème pour l'instant (ça pourrai le devenir... plus tard)
    Je vais néanmoins consulter ton lien, au cas où qq chose m'aurai échappé.

    Mais je veux réussir le flashage et télécharger Opentx (ce que je n'arrive pas à faire) ensuite je verrai en détail chaque chose.

  9. #318
    Membre Sénior Avatar de F1FNW
    Inscrit
    juin 2008
    Localisation
    Corsica.
    Messages
    1 910
    Merci / J'aime
    Cité(e)
    8 Post(s)
    Badgé(e)
    0 Sujet(s)
    Citation Envoyé par xavtronic Voir le message
    Bonjour,

    Je reviens sur le sujet car je n'ai pas pu beaucoup avancer ces derniers temps et je n'ai pas encore effectué toutes les commande nécessaire!

    Je me pose la question sur ces switch de navigation peuvent avantageusement remplacer ceux préconiser dans l'article?
    http://www.aliexpress.com/item/Size-...2_73_74_75,0_0



    L'écran LCD vous confirmer que le meilleure prix est celui-ci (environ 6$ par pièce)?
    http://www.aliexpress.com/item/4pcs-...2_73_74_75,0_0

    Xavier
    Oui les deux produits de ces liens sont valables le premier tu as 5 pièces et le second le prix (tu as dû voir) est pour 4 pièces... si tu en a l'utilité. ce sont tout deux des composants préconisé par Franck.

  10. #319
    Membre actif Avatar de xavtronic
    Inscrit
    septembre 2004
    Localisation
    Suisse
    Messages
    708
    Merci / J'aime
    Cité(e)
    0 Post(s)
    Badgé(e)
    0 Sujet(s)
    Hello,

    @F1FNW

    Essaye avec le type de programmateur "stk500".

    Tu es également sur de lien vers le logiciel "avrdude"?


    Merci pour la confirmation des boutons de navigation, vu qu'il n'y a pas de référence et que celle donnée par Franck n'est pas facilement trouvable ici, je me posais la question.
    Les écrans je me posais la question s'il y a une source encore meilleure marché, mais 4 écrans permet de bricoler autre chose aussi! J'ai déjà des ST7920, mais j'aimerais quelque chose de plus petit.
    L'idéal serait des types OLED de 1-2pouce qui travaillent avec un drivers SSD1306.


    A+
    Xavier
    Dernière édition par xavtronic; 30/09/2015 à 14h37

  11. #320
    Cz&Co Avatar de Franck.A
    Inscrit
    juin 2005
    Messages
    7 638
    Merci / J'aime
    Cité(e)
    3 Post(s)
    Badgé(e)
    0 Sujet(s)
    Citation Envoyé par F1FNW Voir le message
    ensuite, je vais sous companion 2.1 et je règle la communication comme indiquée
    Je voudrais surtout voir le texte du log affiché lors de la tentative de flash (là où il y a 0% d'avancement). Cela renseignera sur les paramètres de flash réellement utilisés par Companion et devrait expliquer au moins en partie le problème.

    Citation Envoyé par xavtronic Voir le message
    Une question plus technique pour Franck qui me trotte dans la tête depuis la parution de l'article et concernant le choix de l'arduino Mega, pourquoi ne pas avoir utiliser la DUE?
    Elle n'exitait pas à l'époque. Mais j'ai effectivement hésité avec d'autres cartes, et ce qui m'a fait choisir la Mega est son faible coût et le portage en partie pré-mâché car cette carte utilise le même µP que la Gruvin9x.

    Citation Envoyé par xavtronic Voir le message
    @Franck : quel est la configuration des options minimum qui fonctionne? (pour le HEX de Open-tx)
    Choisir seulement l'écran suffit pour un test.
    RC Aero Lab : PredimRC, radio DIY OpenTX NextStepRC, conception et optimisation d'aéromodèles.

Page 32 sur 207 PremièrePremière ... 222526272829303132333435363738394282132 ... DernièreDernière

Sujets similaires

  1. CF4 TT 1/10 MBGO - Gonfreville l'orcher - 13-14 juin 2015
    Par philippe27 dans le forum Auto / Compétitions & Rencontres
    Réponses: 1
    Msg: 16/06/2015, 23h59
  2. Rencontre PPR LARZAC juin 2015
    Par serbin dans le forum Aéro / Planeurs
    Réponses: 1
    Msg: 25/05/2015, 22h47
  3. Réponses: 0
    Msg: 12/03/2015, 15h01
  4. [Ventes] radio Eurgle 9X (FlySky, Turnigy) OpenTX FrSky 2.4
    Par davx dans le forum P.A. / Aéro / Radio & Electronique
    Réponses: 0
    Msg: 06/05/2014, 11h14
  5. Le samedi 6 juin et dimanche 7 juin 2009 WE planeur/remorqueur 34
    Par ludovictz dans le forum P.A. / Aéro / Planeurs
    Réponses: 0
    Msg: 01/06/2009, 21h30

Tags pour ce sujet

Règles des messages

  • Vous ne pouvez pas créer de sujets
  • Vous ne pouvez pas répondre aux sujets
  • Vous ne pouvez pas importer de fichiers joints
  • Vous ne pouvez pas éditer vos messages
  •  
  • Les BB codes sont Activés
  • Les Smileys sont Activés
  • Le BB code [IMG] est Activé
  • Le code [VIDEO] est Activé
  • Le code HTML est Désactivé