Page 520 sur 524 PremièrePremière ... 320420470495512516517518519520521522523524 DernièreDernière
Résultats de 2 596 à 2 600 sur 2620

Sujet : OpenAVRc

  1. #2596
    Membre actif
    Inscrit
    février 2016
    Localisation
    94LqB
    Messages
    457
    Merci / J'aime
    Téléchargement
    0
    Cité(e)
    1 Post(s)
    Badgé(e)
    0 Sujet(s)
    Bonjour à tous,

    Je viens d'installer sur ma radio de vol la version 3.21. Apres avoir sauvegardé firmeware et modèles de la version 3.18 que j'utilisait jusque là.

    Suite à la mise a jour de la version Open AVRC avec la 3.21 et chargement des modèles précédemment sauvegardés, j'ai une erreur de vérification après le chargement des modèles Fichier joint 160244 Cette erreur ne semble pas avoir d'influence sur le fonctionnement
    , il semblerai que tous mes modèles soient présent.

    J'ai maintenant une page avec le bluetooth Fichier joint 160245 et pour le câblage, je propose le schéma suivant : Fichier joint 160246 Sur ce schéma, je n'ai pas raccordé l'alim du module Bluetooth sur la sortie arduino BT_OnOff car je pense que l'intensité doit etre limite et je ne voudrais pas griller ma carte. j'ajouterai après un transistor pour gerer l'alim, mais pour des essais, il mem semble possible d'alimenter directement le module HC05.

    En ce qui concerne les remarques de soft
    Variable globale ajustable jusqu'à 125 alors que l'affichage n'allait que jusqu'à 120 => OK toute les valeurs sont maintenant limitées à 120
    Impossibilité de mettre une valeur négative dans une VG => OK
    Dans les fonctions spéciales, lire fichier le texte associé au message 000 ne s'affichait pas => OK
    Dans les fonctions retard, il semblerai que le fonctionnement soit correct après un premier fonctionnement. En cas de changement de paramètre, a la première mise en œuvre de la fonction, c'est encore les anciens paramètres qui sont actifs, puis ensuite tout rentre dans l'ordre.
    Serait -il possible d'avoir les possibilités et le fonctionnement du Bluetooth pour savoir quoi tester, sachant que je n'ai qu'une radio et donc je ne pourrait pas tester l'intégralité de la fonction écolage.

    Merci

    Salutation
    Dernière édition par guilm; 13/01/2021 à 17h06

  2. # ADS
    Circuit advertisement OpenAVRc
    Inscrit
    Always
    Localisation
    Advertising world
    Messages
    Many
     

  3. #2597
    Diy à donf ! Avatar de Bracame
    Inscrit
    février 2012
    Localisation
    NEGREVILLE
    Messages
    1 075
    Merci / J'aime
    Téléchargement
    44.8 Ko
    Cité(e)
    2 Post(s)
    Badgé(e)
    0 Sujet(s)
    Citation Envoyé par guilm Voir le message
    Bonjour....
    Salut Guilm,

    Merci de dire que j'ai bien bossé sur le firmware (Par moment ça fait plaisir).

    Tes "fichiers joint" sont illisible ici. Encore un bug du forum ? Je sais pas.

    Concernant "les possibilités et le fonctionnement du Bluetooth pour savoir quoi tester".

    UNE SOLUTION : Ha ha !, un truc nouveau qui n'héxiste QU'avec OpenAVRc !!
    ... hum surement, peut être....

    Lire la doc (menu Aide/Doc en ligne/ "manual" ...)

    C'est pas fort ça ??

    Oui, je sais .

    Bonne soirée.

    Christophe

  4. #2598
    Membre actif
    Inscrit
    février 2016
    Localisation
    94LqB
    Messages
    457
    Merci / J'aime
    Téléchargement
    0
    Cité(e)
    1 Post(s)
    Badgé(e)
    0 Sujet(s)
    Citation Envoyé par Bracame Voir le message
    Merci de dire que j'ai bien bossé sur le firmware (Par moment ça fait plaisir).
    Je crois l'avoir déjà répété a plusieurs reprises ! ! et j'ajoute le coté disponibilité pour pouvoir se lancer dans ce projet sans hésitation

    Citation Envoyé par Bracame Voir le message
    Tes "fichiers joint" sont illisible ici. Encore un bug du forum ? Je sais pas.
    Je sais pas moi même un coup je vois les photos puis ensuite j'ai juste le nom de fichier ! ! je les remets ici pour voir si c'est mieux. Cablage, OpenAVRc-img_20210113_111633.jpg erreur au chargement des modèles OpenAVRc-img_20210113_143840.jpg

    Citation Envoyé par Bracame Voir le message
    Lire la doc (menu Aide/Doc en ligne/ "manual" ...)
    Effectivement très très bonne idée ! ! ! Dans la précipitation je n'ai pas pensé que la doc était a jour sur le sujet.
    Dernière édition par guilm; 13/01/2021 à 21h40

  5. #2599
    Membre actif
    Inscrit
    février 2016
    Localisation
    94LqB
    Messages
    457
    Merci / J'aime
    Téléchargement
    0
    Cité(e)
    1 Post(s)
    Badgé(e)
    0 Sujet(s)
    Bonsoir,

    Apres avoir vérifié la consommation de mon module Bluetooth qui se situe aux alentours de 45 mA, j'ai ajouté un transistor afin de ne pas griller la sortie Arduino. Voici le schema modifié.OpenAVRc-schemza-racc-bt.jpg En espérant qu'il soit lisible.

    Juste pour info, dans Windows 10 une fois le module installé, on a deux port com, un entrant et un sortant, lequel est à indiquer dans "Desktop". Je n'ai pas encore câblé le module dans l'émetteur, je l'ai juste fait causer avec le PC pour l'instant ! !

    Bonne soirée Cdlt

  6. #2600
    Membre actif
    Inscrit
    février 2016
    Localisation
    94LqB
    Messages
    457
    Merci / J'aime
    Téléchargement
    0
    Cité(e)
    1 Post(s)
    Badgé(e)
    0 Sujet(s)
    Bonjour,

    Pour info,
    Mes premier essai, avec un module Bluetooth HC 05 acheté sur Ali****il y a maintenant quelques temps, ne sont pas très concluant,
    Le schéma que j’ai mis sur le forum avec un transistor ne fonctionnement pas car la sortie BT_OnOff fonctionne en inverse. (Sortie arduino à 1 quand le Bluetooth n’est pas activé). Les essais ont été fait avec le module alimenté en permanence.
    Apres mise sous tension et attente de 30s, => message Bluetooth muet.
    A l’oscillo, les signaux on des niveaux qui semblent correct avec l’adaptateur de niveau. Le module Bluetooth reçoit bien des ordres car il se met à clignoter des que l’on essaie de l’activer depuis l’émetteur.

    Observation : A l’oscillo lorsque le module n’est pas activé, on a une trame qui est envoyée au module environ toutes les 35ms, alors que si on cherche a activer le module (sigle Bluetooth a l’écran de l’émetteur) on a une trame très courte envoyée de manière « aléatoire que je n’arrive pas à synchroniser avec l’oscillo.

    Voilà les premières observations, si quelqu’un a des pistes, je suis preneur A suivre ! ! !

    Cdlt

Page 520 sur 524 PremièrePremière ... 320420470495512516517518519520521522523524 DernièreDernière

Tags pour ce sujet

Règles des messages

  • Vous ne pouvez pas créer de sujets
  • Vous ne pouvez pas répondre aux sujets
  • Vous ne pouvez pas importer de fichiers joints
  • Vous ne pouvez pas éditer vos messages
  •  
  • Les BB codes sont Activés
  • Les Smileys sont Activés
  • Le BB code [IMG] est Activé
  • Le code [VIDEO] est Activé
  • Le code HTML est Désactivé