Page 580 sur 581 PremièrePremière ... 380480530555572576577578579580581 DernièreDernière
Résultats de 2 896 à 2 900 sur 2902

Sujet : OpenAVRc

  1. #2896
    Membre actif
    Inscrit
    février 2016
    Localisation
    94LqB
    Messages
    567
    Merci / J'aime
    Téléchargement
    0
    Cité(e)
    2 Post(s)
    Badgé(e)
    0 Sujet(s)
    Citation Envoyé par pierrotm777 Voir le message
    Guilm bonjour,

    Voici la solution à tes déboires avec Ms16.
    En fait j'avais le même problème que toi.
    Le firmware n'était pas le bon.
    Github a été mis à jour à l'instant.
    C'est toujours le version V0.3.
    https://github.com/Ingwie/OpenAVRc_H..._Ms16_ProMicro

    Pour charger le firmware dans Ms16, j'utilise 32u4_hexuploader .

    Amuses toit bien ENFIN avec Ms16.
    Bonsoir,

    J'ai pas pu résister ! ! CA MARCHE ! ! ! Il est vraiment ........

    Merciiiiii. Je vais poursuivre mes tests. Avec Putty, ca semble fonctionner, mais on ne voit pas ce que l'on tape comme commande. Avec l'IDE Arduino, pour l'instant les commandes ne fonctionnent qu'une fois.
    On a quand même en permanence le message Failsafe !

    Bonne soirée à tous et encore une fois Merci aux développeurs
    Cdlt

  2. #2897
    Nouveau membre
    Inscrit
    janvier 2021
    Messages
    15
    Merci / J'aime
    Téléchargement
    0
    Cité(e)
    0 Post(s)
    Badgé(e)
    0 Sujet(s)

    Post Arrêt des messages Failsafe

    Bonsoir à tous,

    J'ai tous repris sur le PC Win10 de ma fille pour mettre le problème en évidence, et j'ai reproduis ton problème ainsi que celui de Pierrot. D'où la mise à jour du HEX sur le dépôt Github. Moi, j'ai utilisé la version modifiée de Xloader pour charger le HEX dans l'arduino Pro Micro qui contenait le bootloader.
    Désolé pour ces déboires, j'avais mal généré le HEX de la version V0.3.
    Citation Envoyé par guilm Voir le message
    On a quand même en permanence le message Failsafe !
    Cdlt
    Dès que tu pilotes une sortie, par exemple par le commande S01=1, les messages Failsafe vont s'arrêter.
    Citation Envoyé par guilm Voir le message
    Avec Putty, ca semble fonctionner, mais on ne voit pas ce que l'on tape comme commande.
    Il suffit juste que tu coches "echo local" dans les réglages de PuTTY.

    Moi, j'ai utiliser le terminal Teraterm, mais PuTTY le fait aussi très bien.

    Lis le manuel d'utilisation de MS16-Xany, connecte des servos et des LED pour bien assimiler le fonctionnement.
    Attention quand même, si tu ne connectes pas d'alimentation externe, c'est l'USB de ton PC qui alimente MS16-Xany et les servos et les Leds.

    RC Navy

  3. #2898
    Diy à donf ! Avatar de Bracame
    Inscrit
    février 2012
    Localisation
    NEGREVILLE
    Messages
    1 138
    Merci / J'aime
    Téléchargement
    44.8 Ko
    Cité(e)
    2 Post(s)
    Badgé(e)
    0 Sujet(s)
    Citation Envoyé par RC Navy Voir le message
    Bonjour à tous,

    je constate avec plaisir qu'il commence à y avoir des amateurs pour MS8-Xany et pour MS16-Xany. Il en aura donc peut-être pour Xany2Msx, Xany2Misc ainsi que pour les modules développés par Pierrot (ex: Xany2Sounds).
    .....
    Comme le rappelle Christophe, il y a plusieurs mois de celà, il avait évoqué la possibilité d'intégrer ces flashages directement dans Desktop.....
    RC Navy
    Bonsoir,

    Je vais "jongler" entre cet ajout et le debug du protocole Hitec (Mon banc test est de nouveau opérationnel) .... Mais ça risque de prendre un peut de temps

    Premier point pour ne pas refaire le travail dans quelques mois : On va changer de version avrdude.

    Cette version semble avoir une méthode pour flasher "facillement" les pro micros via usb vid/pid ..... A tester messieurs

    Je souhaite aussi que le futur avrdude utilisé dans OpenAVRc soit capable de flasher un Xmega via un usbasp modifié en pdi.

    -> Je cherche ...

    Désolé pour ceux à qui je donne des maux de tête .

    Flasher les xmega permettra une pleine utilisation du projet de sloped-soarer (co-développeur OpenAVRc) : OpenEVO

    OpenAVRc-dsc_1440.jpg

    Bonne fin de soirée.

    Christophe

  4. #2899
    Membre actif
    Inscrit
    février 2016
    Localisation
    94LqB
    Messages
    567
    Merci / J'aime
    Téléchargement
    0
    Cité(e)
    2 Post(s)
    Badgé(e)
    0 Sujet(s)
    Bonjour,
    Citation Envoyé par Bracame Voir le message

    Cette version semble avoir une méthode pour flasher "facillement" les pro micros via usb vid/pid ..... A tester messieurs

    Je souhaite aussi que le futur avrdude utilisé dans OpenAVRc soit capable de flasher un Xmega via un usbasp modifié en pdi.
    Heeuuuuu la effectivement pour moi, un cachet d'aspirine et au lit ! !!

  5. #2900
    Membre actif
    Inscrit
    février 2016
    Localisation
    94LqB
    Messages
    567
    Merci / J'aime
    Téléchargement
    0
    Cité(e)
    2 Post(s)
    Badgé(e)
    0 Sujet(s)
    Citation Envoyé par RC Navy Voir le message
    Bonsoir à tous,

    J'ai tous repris sur le PC Win10 de ma fille pour mettre le problème en évidence,
    Attention de ne pas priver les enfants de leur outil de travail ! !

    Citation Envoyé par RC Navy Voir le message
    Dès que tu pilotes une sortie, par exemple par le commande S01=1, les messages Failsafe vont s'arrêter.
    OK ca marche impec.

    Citation Envoyé par RC Navy Voir le message
    Il suffit juste que tu coches "echo local" dans les réglages de PuTTY.
    Effectivement ca marche, du coup c'est plus pratique de voir la requête et la réponse

    Citation Envoyé par RC Navy Voir le message
    Moi, j'ai utiliser le terminal Teraterm, mais PuTTY le fait aussi très bien.
    J'ai essayé avec les deux et meme avec l'ide Arduino, et tout marche !

    Citation Envoyé par RC Navy Voir le message
    Lis le manuel d'utilisation de MS16-Xany, connecte des servos et des LED pour bien assimiler le fonctionnement.
    Attention quand même, si tu ne connectes pas d'alimentation externe, c'est l'USB de ton PC qui alimente MS16-Xany et les servos et les Leds.
    Ca commence a faire un petit un moment que je regarde le manuel d'utilisation, et je viens d'essayer toutes les commandes sans problème ! !
    Pour les alims si on veut faire le paramétrage, il est préférables de le faire avec juste l'USB de branché sans les sorties et sans alim exterieure. Cela évite les conflits entre le 5v USB et l'alim externe. On alimente avec l'alim externe juste pour faire les essai une fois le paramétrage terminé.

    Mon aventure n'est malgré tout pas terminée ! ! je passe maintenant cote emetteur. Je viens de paramétrer X-Any sur la voie 6 et avec les 8 inters logiques, n'ayant pas encore câblé l'option cote emetteur.
    Et la je me trouve confronté a une difficulté. Je vois bien les inters changer d'etat sur la page X-Any mais coté reception, ca ne fonctionne pas. J'ai la led Pas de signal qui est allumée et je vois sur la première page de l'emetteur le bar graph de la voie 6 qui n'arrête pas de passer du mini au maxi ! ! ! Essai a suivre ! ! !

    cdlt.

Page 580 sur 581 PremièrePremière ... 380480530555572576577578579580581 DernièreDernière

Tags pour ce sujet

Règles des messages

  • Vous ne pouvez pas créer de sujets
  • Vous ne pouvez pas répondre aux sujets
  • Vous ne pouvez pas importer de fichiers joints
  • Vous ne pouvez pas éditer vos messages
  •  
  • Les BB codes sont Activés
  • Les Smileys sont Activés
  • Le BB code [IMG] est Activé
  • Le code [VIDEO] est Activé
  • Le code HTML est Désactivé