Bonjour à tous,

En voyant ce que le Disco de Parrot sait faire, je me suis dit que j’allais faire pareil avec mon Tundra, pour me lancer dans le FPV .

Je me suis donc procuré :

  • Un contrôleur de vol WING FC-10, à configurer avec INAV, flashé au dernier firmware
  • Un émetteur video et un Runcam Eagle 2
  • Un GPS TBS M7


J’ai déjà l’avion,

  • une radiocommande DX8 (première version)
  • Des récepteurs Orange RX en CPPM et sbus et un récepteur REDCON CM07 en PPM


J’ai deux soucis : un pour le contrôle de mes voies et un pour l’utilisation du GPS

1/ Je parviens à faire bouger mes voies seulement avec le REDCON en PPM, mais avec une limitation majeure, c’est que les voies attribuées par INAV ne sont pas les mêmes que celles de ma radio, ainsi quand je bouge les gaz, c’est le yaw (ou pitch ou roll, je ne sais plus).
J’ai fouillé le net et ai compris que le PPM se déclinait en plusieurs versions TAER, AERT, REAT (et que cela joue sur l’ordre des voies).
N’ayant pas trouvé le moyen de changer l’affectation de mes voies sur ma DX8, je me dit que c’est KO, du moins avec ce récepteur.

Je n’ai pas réussi à faire fonctionner les récepteur Orange RX720 V2, pourtant en mode SBUS… toutes les voies semblent bouger, toutes seules, dans tous les sens.
Existe-t-il des convertisseurs PPM REAT vers TAER ou AERT ?
Suis-je un manche ou y a-t-il moyen, selon vous de changer les affectations de voie sur ma DX8 (SPM8800)?
Et s’il y a moyen, l’affectation des voies est-elle un paramètre propre à un émetteur ou à une radio (autrement dit, un changement d’affectation de vois impacte-t-il tous les modèles enregistrés sur la radiocommande).
Quel autre moyen voyez-vous pour faire tourner le système (idéalement sans changer de télécommande) ?

2/ GPS
Mon GPS fonctionne et me localise bien.
INAV le reconnait et j’ai bien une douzaine de satellites.
Je souhaite visualiser sur l’OSD de mon masque FPV : la direction de la « Maison », la distance de la « maison ».

J’ai fait différentes tests (à blanc – sans l’avion, et sans moteur, en m’éloignant à pied, avec le système à plus de 100m) et ces 2 fonctions ne donnent rien (la « Distance to Home » reste à 0 et la « Direction to Home » aussi). Par contre, le paramètre « heading error to Home » semble lui fonctionner (j’en suis même pas vraiment sur)

Faut-il que le système soit armé pour initialiser « la maison » ?
Des idées pour solutionner le pb ?

Merci à tous d’avance pour vos contributions…j’ai déjà passé quelques heures pour solutionner ces 2 pb, en vain.