PDA

Afficher la version complète : FCWii... la synthèse!



F1FNW
26/05/2011, 15h20
Bonjour à tous,

Le titre de ce post peut sembler prétentieux, mais il n'en est rien et ce n'est surtout pas mon intention.
Après avoir lu et relus les quelques 600 messages de la rubrique consacrée à la FCWii et comme beaucoup d'entre nous avoir pas mal ramé, je pense enfin voir le bout du tunnel. J'ai tout repris à zéro sur mon portable car j'avais quelques problèmes et pas de solutions.
Je voudrais donc (en toute modestie) vous faire part de ma démarche.

J'ai donc repris le fichier vierge 1.7 et dans un premier temps, je n'ai modifié que le modèle à faire voler: Un quad en X à la place du TRICOPTERE proposé d'origine.

Ma configuration est la suivante:

Emetteur FUTABA FC28 V3 en 2.4GHz et Rx CORONA CR8D (3 voies de trop!!!)

La carte fixée bien horizontalement sur le chassis, WMP et NUNCHUK en place.

Les ESC reliés suivant le modèle du quad en X le 1 au 1, le 2 au 2 etc..

Les sorties Rx (correspondant au standard FUTABA)

Voie 1 = ROLL
Voie 2 = PITCH
voie 2 = THROTTLE
voie 4 = YAW
voie 5 = STABLE

Le module FDTI câblé et relié sur son connecteur.

Tous les manches au neutre, les gaz au mini trim inclus

MISE SOUS TENSION d'un accu 3S des bips par ici et par là la LED rouge clignote ainsi que la verte (plus rapidement) c'est la phase d'initialisation puis la LED verte allumée en fixe (c'est bon) et la rouge clignotante (c'est normal).

Je lance l'interface JAVA GUI et je sélectionne mon port COM (le 4 chez moi) et je clique sur START. Les courbes sont visibles à l'écran, tout semble normal

Voici les paramètres relevés:

NUNCHUK coloré en vert (c'est bon)

Au repos les sorties ESC indiquent FL et FR = 1300
RL et RR = 1300

Mes valeur issue de mon émetteur sont:

Gaz mini 911, maxi 2013
Pitch mini 967, neutre 1460, maxi 1947
Roll mini 1008, neutre 1517, maxi 2036
Yaw mini 1060, neutre 1518, maxi 1974

La voie 5 fait varier simultanément:
AUX1, AUX2, CAM1, CAM2 d'un mini de 951, neutre 1498, maxi 2051.

On peux voir que ces valeurs sont assez disparates, on doit pouvaoir les corriger avec les TRIM (mais est-ce bien utile???) je sais pas...

Je suis en mode 2 sur mon Tx et je met donc la voie YAW gaz mini et manche a DROITE pour armer les moteurs la LED verte s'allume fixe au bout de 2 secondes indiquant les ESC armés.

Je pousse le manche des gaz (pas d'hélice bien sûr!!!) les moteurs démarrent... mais tous en même temps (haï, haï, haî)

En effet:
le premier à démarrer est le 3
Le deuxième le 1
le troisième le 4
le quatrième le 2

Cela est obtenu en poussant le manche des gaz cran par cran, si je monte les gaz plus rapidement, les moteurs semble démarrer simultanément, enfin presque car le 2 est à la traine.

Lorsque le manche est à MIS GAZ, une action sur le YAW ou sur le PITCH ou sur le ROLL fait varier les régimes des différents moteurs et on peut observer les variation sur l'interface GUI.

Si je prend le QUAD en main et que je l'incline dans tous les sens, les variations de régime sont également bien perceptibles.

Pour essayer de contrer le démarrage laborieur du moteur 2, j'ai essayé différentes modif dans le code source de l'ARDUINO. j'ai un peu amélioré le problème mais pas supprimé.

Voilà, j'espère que cette petite synthèse pourra aider certains d'entre nous, il ne me reste plus qu'à monter les hélices et voir en live ce que ça donne...

Pour mon problème, vos suggestions ou votre expérience sont les bienvenus.

F1FNW
26/05/2011, 16h11
Quelques photos de l'engin... on sait jamais!!

andreas-aeromodelisme
27/05/2011, 12h45
a tu étaloné tes esc ?

F1FNW
27/05/2011, 17h15
Salut,

Oui j'ai étalonné les 4 ESC premièrement un par un, puis les 4 ensembles après avoir fabriqué un cordonc muni de 4 prises mâle proposé par "JIVAGO" sur un autre post. (très astucieux). Bon à présent mes moteurs tournent mes voies sont toutes dans le bon sens, j'ai vérifié en tenant l'appareil à bout de bras suivant la méthode décrite "réglage du PID". Par contre je n'ais pas affiné le PID. l'appareil réagit correctement mais les compensations ne sont pas parfaites, il faut encore régler. Je crois que je tiens le bon bout!

A bientôt

NutSpirit
28/05/2011, 19h32
J'ai fait le maiden flight de mon quadri équipé en FCwii v1.7 cette semaine avec les réglages PID par défaut : il vole à merveille :*) je n'ai rien à changer !

Faut se lancer ! ça fait tout voler cette carte !